This project is read-only.

Target Namespace

Sep 29, 2011 at 7:31 PM

This is all great stuff. I started implementing the DomainContext stuff and bumped up on that implementation myself. It would be great if tehre was a way to specify the target namespace for the code that is spit out. I can user R# and change the namespace for all these things, but it feels like I'm using a hammer.

What are some ways you suggest handling the target namespace issue?

Sep 29, 2011 at 7:45 PM

Ok so after doing some research I was able to do this in mass with R#. Still it would be nice to have an option to do this from the get go, i.e. 

Install-Package NetFx-xxxx -Namespace MyAwesomeProject.Core

Of course I'm not sure what the update story will be for package updates once I move the files, but that's neither here nor there now.

Once again thanks, and kudos for the great project.

Nov 29, 2011 at 3:04 PM

Hi, Where you able to fork the repo and clone it successfully, I get an error like the repo is corrupted. See my disussion for details.

Nov 29, 2011 at 3:08 PM

I didn't go as far as forking the repo, so I'll be of no help to you.

Nov 29, 2011 at 3:11 PM

Well it actually doesnt matter, I tried to clone the original repo and I get the same error so I think what once worked doesnt anymore. If you dont mind could you try to a clone to a temp folder and see if you get an error.

Nov 29, 2011 at 3:17 PM

Actually I take it back, I did clone the repo previously and it seemed to work. (I'm no Mercurial expert I cloned using TortoiseHg and it worked for me). 

Nov 29, 2011 at 3:21 PM

I also did this before successfully but cant now. I'm trying to establish if there is a problem with the codeplex repo. If there is I think it needs to be raised with codeplex. Could you try to clone it now if it isnt too much trouble?

Nov 29, 2011 at 3:30 PM

Okay, it was crazy slow, but it worked.

hg clone --verbose -- C:\hg\CodePlex\netfx2

Nov 29, 2011 at 3:39 PM

Well that is strange, when I do it I get this

% hg clone --verbose -- D:\My Documents\Visual Studio 2008\Projects\netfx2
requesting all changes
adding changesets
adding manifests
adding file changes
added 191 changesets with 4586 changes to 3476 files
updating to branch default
resolving manifests
getting .hgignore
getting Common.ps1
getting Drop.ps1
getting Extensions/Microsoft/ApplicationServer/Http/HttpWebService/Build/Build.csprojgetting Extensions/Microsoft/ApplicationServer/Http/HttpWebService/Build/NuGet/License.txt

<cut ........>
getting Extensions/System/Net/Http/HttpEntityConventionClient/packages/netfx-Microsoft.ApplicationServer.Http.JsonNetMediaTypeFormatter.

abort: D:\My Documents\Visual Studio 2008\Projects\netfx2\Extensions/System/Net/Http/HttpEntityConventionClient/packages/netfx-Microsoft.ApplicationServer.Http.JsonNetMediaTypeFormatter. The system cannot find the path specified[command returned code 255 Tue Nov 29 15:34:35 2011]

It always fails on this last file for me.

Nov 29, 2011 at 3:42 PM

Once again, not speaking as an expert, but maybe try getting it into a shorter root directory path... the file path for that file is pretty long so yopu may be bumping into issues with path lengths. This might just be a case of a poor error message.

Nov 29, 2011 at 3:54 PM

Good catch you where right.. Now I'd say the fault is with mecurial not supporting long filenames that ntfs supports.